<artifactId>spring-boot-maven-plugin</artifactId>报错问题

本文最后更新于:2023年10月21日 晚上

前言

<artifactId>spring-boot-maven-plugin</artifactId>报错问题

我用的软件是IDEA,在pom.xml文件中,遇到spring-boot-maven-plugin这一行一直是红色,提示没有找到

maven中其他包没有问题,只有这个有问题

1
2
3
4
5
6
<plugins>
<plugin>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-maven-plugin</artifactId>
</plugin>
</plugins>

加上版本号就ok了

1
<version>2.2.1.RELEASE</version>
1
2
3
4
5
6
7
<plugins>
<plugin>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-maven-plugin</artifactId>
<version>2.2.1.RELEASE</version>
</plugin>
</plugins>